sea side she side

写真と山、資格が好きなアラフォーエンジニアのブログ

Ruby on Rails with Mac OS X 10.5 (1)

      2011/03/19

10.5にはRoRがすでにインストール済みということでいろいろさわってみようと思った。だけどRailsのVersionが2.0.2ということで:modelが使えない。世界にあるチュートリアルを試すにも2.0.2では厳しいものがある。まずRailsのDowngradeからはじめる。

$ sudo gem uninstall rails
$ sudo gem install rails --version 1.1.6
$ rails -v

svnを使っていくがTortoiseSVNっぽいものがMac用にもあるのでそれを利用する。

http://scplugin.tigris.org/

ここからDownloadしてインストール。再起動後、右クリックするとその他>Subversionというのが追加されている。

レポジトリの追加を行う。

$ svnadmin create svnroot
$ svnserve -d
$ vi ~/svn/conf/svnserve.conf
anon-access = read
auth-access = write
password-db = passwd
$ vi ~/svn/conf/passwd
user = pass

rails作業ディレクトリを追加。

$ cd
$ mkdir rails
$ cd rails
$ rails Todo

ここでエラーがでまくりんぐ。Google様にお問い合わせすると、いろいろ足りていないらしい。

$ sudo gem install activesource

のようにインストールしていく。だいたいエラーがでるのはこのあたり。

  • actionpack
  • actionmailer
  • activeresource
  • activerecord
  • activesupport

エラーが消えてTodoが作成できたらFinderからTodoフォルダをcheckoutする。その際のurlは、

file://localhost/Users/username/svn

とする。

 - IT